Tento web používá k poskytování služeb, personalizaci reklam a analýze návštěvnosti soubory cookie. Používáním tohoto webu s tím souhlasíte.

Retry s.r.o., Vondrákova 1254/2a, 635 00 Brno, Czech Republic pin-map  tel.: +420 549 210 082, email: infoproti spamuedatools.cz

Úvod do Altium Designeru VI. - návrhová pravidla a DRC

ad_serial_logoPokud řešíte návrh složitější desky plošných spojů, tak je dobré znát všechny nástroje, které Altium Designer nabízí, aby „routování“ (kreslení spojů na desce) šlo snadněji a především v něm nebyly chyby.

 

 

To hlavní co je potřeba důkladně nastudovat a nastavit, jsou návrhová pravidla, která jsou základním stavebním blokem systému DRC (Design Rules Check, kontrola návrhových pravidel). Návrhový systém Altium Designer (AD) se při vytváření plošného spoje řídí návrhovými pravidly a umožňuje nám tak kreslit plošný spoj, který je z větší části kontrolován v průběhu jeho vytváření, respektive systém nedovolí pokládat spoje v menší než v minimální dovolené vzdálenosti, používat příliš malé prokovené otvory apod. Pravidla jsou z hlediska AD soubor parametrů, který je nutné dodržet. Jedná se o základní DFM (Design for Manufacturability, navrhování pro jednoduchou vyrobitelnost) limity i když AD nemá ambice plně nahradit k tomu určené DFM nástroje.

Z hlediska návrháře se obvykle pravidla pomyslně dělí na dvě skupiny, a to obecná technologická pravidla a pak konkrétní elektrická nebo mechanická omezení - výjimky - dané potřebou konkrétního elektrického zapojení a jeho součástí.

Návrhová pravidla jsou kontrolována a jejich porušení je zobrazováno ve 2D i ve 3D interpretaci plošného spoje (obr. 1.). Vždy tedy vidíte maximum dostupných informací. Pokud chybně umístíte (příliš blízko k nějaké fixní součástce; konektor definovaný normou) například integrovaný obvod v BGA pouzdru se 676 kuličkami, tak jste o tomto informováni vybarvením součástky barvou DRC chyby. Pokud by se návrhář o tomto dozvěděl až na konci návrhu, tak jej čeká odstranění několika set spojů tohoto BGA pouzdra, jeho přemístění a nové natažení spojů. Informace o chybném umístění získaná hned ve chvíli umísťování BGA pouzdra tedy ušetří velké množství času.

010 3Dcollision

Obr. 1. Kolize BGA pouzdra a pevně umístěného konektoru

Návrhová pravidla

Návrhová pravidla (menu Design » Rules [D,R]), neboli soubor požadovaných vlastností u objektů na desce, se v Altium Designeru nezadávají pomocí matice, jak je to u návrhových systémů pro plošné spoje zvykem, ale prostřednictvím vícenásobných pravidel (obr. 2.), která mají omezenou platnost, pomocí filtračního výrazu. Filtračním řetězcem vybereme, pro které objekty na plošném spoji konkrétní pravidlo platí, a nastavíme požadovanou hodnotu mechanických nebo elektrických parametrů objektu. Nejsme přitom omezeni pouze typem objektu nebo příslušností k nějakému signálu, ale můžeme využít i mnoha dalších vlastností. Pravidlo tak může platit například pro pouzdra začínající ve svém názvu na DIP, jejichž výška je menší než 5mm, a zároveň jsou v části desky nazvané CPUspace – (ObjectKind = 'Component') And (Height < AsMM(5)) And (Footprint Like 'DIP*') And TouchesRoom('CPUspace').

020 DesignRules

Obr. 2. Návrhová pravidla v Altium Designeru se dělí na kategorie

Definice filtračních výrazů není tak jednoduchá jako zadávání pravidel maticí, ale podle výrazu uvedeného výše je patrné, jak velkou flexibilitu výrazy přinášejí. Díky širokým možnostem nastavení filtrace objektů je možné vztáhnout pravidla téměř na jakoukoliv situaci na navrhované desce. Pro začínající uživatele je k dispozici Rule Wizard (menu Design » Rule Wizard [D,W]), který vám potřebné pravidlo vytvoří na základě zodpovězení několika dotazů.

Poměrně často je potřebné vytvořit i specializovaná pravidla například pro polygony (vylití mědí) nebo diferenciální páry. Pro práci s polygony je určen oddělený nástroj Polygon Manager, který je v menu Tools » Polygon Pours [T,G,M]. Ten v sobě integruje také průvodce pro vytváření specializovaných pravidel pro polygony. Pro diferenciální páry je specializovaný průvodce Rule Wizard dostupný na panelu PCB (View » Workspace Panels » PCB » PCB) nastaveném na Differential Pairs Editor. Všechny tyto pomocné nástroje vytváří standardní pravidla s filtračními výrazy podle zadání a nastaví požadované hodnoty mechanických vlastností. Po dokončení průvodce jsou tedy pravidla uvedena přímo v Design » Rules, kde je můžete dále editovat. Pravidla se však většinou vytvářejí bez průvodců přímo ve správci pravidel Design » Rules v kontextovém menu (kliknout pravým tlačítkem) vybrané kategorie pravidel položkou New Rule. Pravidlo je vhodné smysluplně pojmenovat.

Pravidla se z hlediska filtračních výrazů dělí na unární a binární typy. Unární typy mají pouze jedno pole s filtračním (Query) řetězcem, zatímco binární pravidla mají filtrační řetězce dva. Jednoduše řečeno u prvního typu určujeme pouze to, pro které objekty je pravidlo platné (např. zadaná šířka spoje platí pro spoj s konkrétním jménem), zatímco u druhého typu můžeme zadat platnost pravidla ve vztahu dvou objektů mezi sebou (např. izolační mezera dané velikosti musí být dodržena mezi dvěma spoji s definovaným jménem).

Filtrační výrazy pravidel

Filtrační výrazy pravidel se zadávají výběrem jedné z přednastavených možností v každém návrhovém pravidle:

  • All – pravidlo platí pro všechny objekty
  • Net – omezení na konkrétní spoj
  • Net Class – omezení na třídu spojů
  • Layer – omezení na vrstvu plošného spoje
  • Net and Layer – omezení na část spoje na určité vrstvě
  • Advanced (Query) – zadání složitějšího výrazu ručně pomocí Query Builderu (sestavením anglické věty popisující zamýšlený objekt se vytvoří řetězec v požadované syntaxi) nebo Query Helperu (ruční zápis výrazu s automatickým dokončováním klíčových slov).

Pro definici filtračních řetězců se používá jazyk Query Language definovaný manuálem TR0110 [1], podrobnosti jsou k nalezení i ve wikipedii Altia [2]. Query jazyk používá standardní logické operátory jako AND, OR a NOT a také pomocné testovací funkce uvozené klíčovým slovem Is nebo In. Is se používá k ověření typu daného objektu (IsPad, IsComponent), zatímco In je použito pro ověření příslušnosti daného objektu k třídě nebo ke spoji z netlistu apod. (InComponentClass, InNamedPolygon). Velmi důležitý je operátor NOT, který dovoluje postavit filtrační řetězec opačnou logikou, tedy popisovat, kterých objektů se pravidlo netýká. To bývá často jednodušší.

Důležité je mít na paměti, že v Query jazyce se nelze odkazovat, tudíž nelze vytvořit výraz typu „najdi vývod součástky s určitými vlastnostmi a pravidlo aplikuj na celou součástku, ke které vývod patří“. Stejně tak nelze filtračním výrazem vyfiltrovat pouze určitou část spoje, část spoje lze popsat pouze pokud se nalézá v Room oblasti. Nelze tedy definovat pravidla pro spoj např. 10mm od některého vývodu apod. Snad na každé omezení ale existuje způsob jak je obejít.

Třídy

Obvyklá je také potřeba vztáhnout určité pravidlo k nějaké specifické skupině spojů, například vysokonapětové signály. To se provádí pomocí tříd (Classes). Třídy existují nejen pro signály, ale i pro součástky (Component Class), diferenciální páry (Differential Pair Class) nebo polygony (Polygon Classes). Některé z těchto tříd lze definovat již ve schématu, čímž je pro návrháře proces jednodušší. Ve schématu definované sběrnice (Bus) jsou například automaticky zahrnuty do tříd pojmenovaných názvem sběrnice. Pravidlo tak lze navázat přímo na danou třídu filtračním výrazem InNetClass('BUS_A[24..1]').

Správu tříd ze strany editoru plošného spoje provádíme prostřednictvím nástroje Tools » Classes. Zde se třídy vytváří a pomocí formuláře se do tříd přidávají jednotlivé elementy (Members).

Několik pravidel v jedné kategorii - priority

Občas se setkávám s názorem, že v kategorii pravidla může být pouze jedno pravidlo. Není tomu tak. Kategorie pravidla (např. Electrical » Clearance) může obsahovat velké množství pravidel. Každé má přitom definovanou hodnotu priority od 1 do 9999. Altium Designer postupuje pravidly od nejnižší hodnoty priorit po nejvyšší a použije pro testovaný objekt první pravidlo, které svým filtračním řetězcem odpovídá testovanému objektu. Priority se nastavují v editoru pravidel tlačítkem Priorities. Pro zjednodušení nastavení je dobré zavést si v prioritách systém. Osvědčené řešení je na první místa uvádět ty nejdetailnější výjimky z pravidel (např. jiná hodnota Clearance pro vývody TQFP pouzdra) následované pravidly definovanými pro jednotlivé třídy (např. zvětšená Clearance pro signály citlivé na rušení zahrnuté do třídy s názvem Sensitive) a uzavřené na závěr nejobecnějším pravidlem s filtračním řetězcem All nebo All-All, které obsahuje technologický limit výroby. V kontextu významu priorit tak poslední pravidlo má definovanou platnost pro všechny zbývající objekty, pro které nebylo vytvořené oddělené pravidlo. Díky této sestavě je alespoň jedním pravidlem z kategorie postižen nutně každý objekt na plošném spoji a je tak kontrolován DRC systémem.

Pravidla podle určení

Význam jednotlivých pravidel je možné jednoduše dohledat, ve většině případů jsou však pravidla pochopitelná z jejich názvu a ilustrace u nich uvedené. Výčet funkcí tedy nepovažuji za nutný. Místo toho si pravidla rozdělíme z dalšího hlediska, kterým je jejich určení, a to na pravidla platná pro:

  • interaktivní editaci – převážná část pravidel, která se používají při interaktivní editaci plošného spoje uživatelem. Patří mezi ně pravidla šířky spoje, elektrické izolační vzdálenosti, topologie vedení spojů (kam má vést signál nejdříve a kam pokračovat), povolení zkratů, definice minimální vzdálenosti komponent, jejich výšky atd.
  • nastavování parametrů objektů – pravidla pro definování vylívání polygonů a motivu připojení plošek k polygonům nebo parametrů napájecích vrstev (celá kategorie Plane), tvorbu nepájivé masky a šablony pájecí pasty, parametrů SMD plošek, definování délek spojů, případně pravidla pro generování testpointů a některá pravidla pro kontrolu vyrobitelnosti.
  • kontrolní pravidla – jsou určená pouze pro batch režim DRC kontroly = pravidla pro signálovou integritu apod.
  • autorouter – pravidla určená pouze pro automatické pokládání spojů nástrojem autorouter. Jedná se o pravidlo pořadí routování (Routing Priority) a tvar záhybů spojů (Routing Corners)

Za pozornost stojí zcela jistě i vlastní parametry pravidel. Nejtypičtějšími zástupci jsou pravidla Width a Clearance. Width je unární pravidlo (bez závislosti na objektech v okolí) definující šířku spoje. Je zde definován rozsah možných hodnot šířky hodnotami Min a Max a preferovaná hodnota Preffered, která musí být mezi těmito hranicemi (to platí analogicky i pro pravidlo Routing Via Style definující prokovené otvory). Pravidlo dovoluje návrháři použít libovolnou šířku spoje v povolených hranicích, v základním nastavení však nabízí preferovanou hodnotu jako první. Šířku je přitom možné nastavit jinou pro každou vrstvu spoje (obvykle podle tloušťky nakovení vrstvy a mechanických požadavků). Pravidlo lze přepnout do režimu Characteristic Impedance Driven Width, kde se místo šířky zadává požadovaná impedance vedení. Ta se automaticky vypočítává ze složení plošného spoje, především ze vzdálenosti spoje od napájecí vrstvy (Plane). Napájecí vrstva je pro tento výpočet nutná. Za pozornost stojí přepínač pravidla Check Track/Arcs Min/Max Width Individually a Check Min/Max Width for Physically Connected Cooper. Tento přepínač rozhoduje o tom, zda DRC systém kontroluje pouze to, zda segment spoje má ve svých vlastnostech uvedenou správnou šířku a zda je elektricky propojený na další segment. Nekontroluje se však šířka tohoto propojení. Tu kontroluje až druhé jmenované nastavení, které je pochopitelně výpočetně náročnější a projeví se na celkové době trvání DRC kontroly. V každém případě by alespoň před finální kontrolou navržené desky měly být všechny tyto přepínače pravidel Width nastaveny na kontrolu Physically Connected Cooper.

Clearance je typickým zástupcem binárních pravidel (dva filtrační výrazy, pravidlo je platné pro vzájemný vztah dvou různých objektů) a stará se o dodržení izolační vzdálenosti mezi dvěma objekty. Typicky se jeden filtrační výraz nastavuje například na třídu vysokonapěťových signálů a do druhého se uvádí výraz All, což znamená, že AD bude mezi všemi signály z vysokonapěťové třídy a všemi ostatními signály udržovat patřičnou izolační vzdálenost. Parametrem pravidla Clearance je nastavení na:

  • Different Nets Only – pravidlo se vztahuje pouze na signály různé od signálu, ke kterému je přiřazen aktuálně kontrolovaný objekt
  • Same Net Only – platí pouze pro objekty v rámci stejného spoje
  • Any Net – pravidlo platí vůči jakémukoliv objektu bez ohledu na jeho příslušnost ke spoji

Pravidlo Clearance patří do skupiny Electrical, nefunguje tudíž pro objekty definované mimo elektrické zapojení – mimo netlist. V AD jsou tyto neelektrické objekty označeny jako No Net. Nelze jej tedy využít ke kontrole vzdálenosti objektů například od hrany desky (neelektrický objekt). Tento úkol se zajišťuje pomocí keepout objektů. Díky možnosti definice objektů filtračním výrazem se však nemusíme omezovat pouze na spoje, ale lze filtrovat třeba typy objektů. Zápisem filtračních řetězců IsVia – IsPad a nastavením parametru Clearance na Any Net nám pravidlo Clearance zajistí automatické udržování prokovených otvorů v definované minimální vzdálenosti od pájecích plošek (omezení odsávají pájky z pájecí plošky) a to přímo v interaktivním režimu. Prokovený otvor tedy již nepůjde do blízkosti plošky vůbec umístit.

Podrobný popis dalších pravidel naleznete na wikipedii Altia pod heslem Design Rules [3].

DRC kontrola

Co je vlastně primárním účelem návrhových pravidel? Především DRC proces, což je automatický proces, při kterém Altium Designer zkontroluje všechny objekty na plošném spoji, zda jsou v souladu s aktuálními pravidly. DRC se provádí ve dvou režimech – online a batch. Online DRC hledá chyby okamžitě při pokládání nových spojů nebo při posouvání součástek na plošném spoji, jednoduše při každé změně. Batch DRC je spouštěno ručně návrhářem a to prostřednictvím menu Tools » Design Rule Check [T,D] tlačítkem Run Design Rule Check (obr. 3.).

Rozhodnutí o tom, zda se konkrétní pravidlo kontroluje v online nebo batch procesu se rovněž nastavuje v menu Tools » Design Rule Check [T,D]. Zde máte možnost pro jednotlivé kategorie zvolit jejich platnost pro online a batch režim, přitom se však předpokládá, že v batch režimu jsou provedeny vždy všechny kontroly a v online pouze ty nejnutnější jako izolační vzdálenosti (Clearance, Short Circuit), šířky spojů (Width), umístění komponent (Component Clearance, Room Definition) a některé z pravidel pro výrobu (Hole Size, Silk to Silk Clearance apod.).

030 DRCdialog

Obr. 3. Aktivace kategorií pravidel pro online a batch DRC

Čím větší je množství pravidel v online režimu, tím déle trvají jednotlivé úkony při pokládání spojů. To samozřejmě závisí i na výpočetním výkonu návrhářova PC. Pravidla pro kontroly délek spojů (Net Match Lengths), vedení paralelních segmentů (Parallel Segments) nebo celá kategorie Signal Integrity tak pro svoji náročnost zůstávají obvykle aktivovaná pouze pro batch režim. Vypnutí online režimu se využívá v počátcích návrhu také pro některá pravidla z kategorie Manufacturing, nejčastěji pravidla minimální šířky masky (Minimum Solder Mask Sliver), kontroly umístění potisku mimo pájecí plošky součástek (Silkscreen Over Component Pads) a vzájemné vzdálenosti částí potisku (Silk To Silk Clearance), nebo se tato pravidla přechodně úplně vypínají. V nastavení kategorie pravidla v Design » Rules jsou zaškrtávací pole Enable, která pravidlo vypnou. Během rozmísťování součástek na plošném spoji a prvním náčrtu spojů totiž obvykle neřešíme potisk a parametry masky, tyto kroky přicházejí na řadu až později. Měli bychom tak zbytečně v DRC hlášena běžně až tisíce porušení pravidel, která nežádoucím způsobem znepřehlední situaci. Velmi důležité je však při takovém postupu zmíněná pravidla opět aktivovat když jsou potřeba.

Výsledkem batch DRC kontroly je seznam porušení pravidel (Violations). V základním nastavení se tento seznam generuje v HTML podobě, která však je spíše informativní (celkové počty chyb v kategoriích a na celé desce). Chyby na plošném spoji ale potřebujeme postupně procházet a opravovat. K tomuto účelu slouží panel PCB Rules and Violations (obr. 4.) z menu View » Workspace panels » PCB. V panelu jsou uvedeny všechny skupiny pravidel. Vybráním jedné nebo několika skupin se nám zobrazí jednotlivá pravidla z těchto skupin a dále vybráním jednoho pravidla se zobrazí v dolní části panelu konkrétní místo s chybou. Kliknutím na tento záznam pak Altium Designer detail místa zobrazí na plošném spoji tak, aby návrhář mohl okamžitě chybu napravit. Chyby se obvykle procházejí postupně podle jejich příslušnosti do dané kategorie, čímž se odstraňování chyb zjednoduší. Panel PCB Rules and Violations je aktualizován i online DRC systémem, takže vybraná pravidla a jejich porušení se zde objevují okamžitě.

040 RulesAndViolations

Obr. 4. Panel PCB Rules and Violations

DRC symboly

Pro zvýraznění míst, ve kterých dochází k porušení návrhových pravidel Altium Designer používá chybové značky. Jejich detailní popis naleznete opět na wikipedii Altia pod heslem DRC Violations [4]. Jednoduše řečeno, porušení pravidel je zvýrazněno překrytím daného objektu (v základním nastavení) světle zelenou barvou se symbolem X, viz obr. 5. Pokud je například celá součástka takto označena zeleně, tak je pravděpodobně moc blízko sousedním součástkám, případně je umístěna mimo svůj vyhrazený prostor (Room). Objekty na plošném spoji mohou však být poměrně rozsáhlé. Místo, kde přesně dochází k porušení pravidel, tak je ještě doplněno tzv. Detail Markerem, který určuje místo i typ chyby. Marker je nejčastěji v podobě kroužku, který svým středem označuje problematické místo a udává, jaký rozměr by měl být dodržen. Dále jsou použity pro některé chyby upřesňující symboly jako zkřížené vodiče pro zkrat (Short Circuit) nebo kruhová „vysílající“ anténka pro nedotažený spoj (Net Antenae). Ještě podrobnější informace o chybě můžete získat kliknutím na objekt v chybovém stavu výběrem položky Violations v jeho kontextovém menu. Zde je uvedeno, jaká pravidla jsou porušena a i vůči jakému objektu.

050 DRCerrors

Obr. 5. Online DRC chyby zobrazené přímo na plošném spoji během editace

Zobrazení chybového stavu má také svá nastavení. Co se týká barev DRC zvýraznění, tak pro ty je nastavení dostupné v menu Design » Board Layers & Colors [L] na záložce Layers jako položky DRC Error Markers a DRC Detail Markers. Další nastavení naleznete v menu DXP » Preferences v kategorii PCB Editor » DRC Violations Display (obr. 6). Klíčový je zde především seznam v dolní části, kterým můžete ovlivnit to, zda se při porušení pravidla daný objekt překryje zvýrazňující barvou (Violation Overlay) a zda bude porušení pravidla doplněno Detail Markerem (Violation Details). Zde také zjistíte, že v základním nastavení není překrývání zvýrazňující barvou nastaveno zdaleka u všech skupin pravidel a to především kvůli zachování přehlednosti. Online DRC kontrola tedy v takovém případě informuje o chybách Detail Markerem a především uvedením chyby v panelu PCB Rules and Violations.

060 DRCdisplay

Obr. 6. Nastavení indikace porušení pravidel

I přes tuto snahu o minimalizaci přímého zobrazení chyb se stává, že je zobrazení plošného spoje nepřehledné. Abychom se mohli v návrhu lépe orientovat, tak je možné chybová hlášení skrýt pomocí funkce Tools » Reset Error Markers [T,M]. Tento reset je platný pouze do dalšího provedení DRC kontroly, která opět zobrazí všechna porušení návrhových pravidel jako dříve. Nejde tedy o permanentní změnu.

Export a import návrhových pravidel

Návrhová pravidla, pokud máme na mysli kompletní sadu se všemi výjimkami a technologickými omezeními, je časově náročné vytvořit. Je tedy přirozené, že sady pravidel se stávají poměrně důležitou proprietou každého návrháře. Altium Designer je umožňuje exportovat z existujícího souboru PcbDoc a importovat je zpět do jiného souboru. Tyto funkce jsou dostupné v menu Design » Rules v kontextovém menu stromu kategorií pravidel (kliknout pravým tlačítkem například na kořen stromu nazvaný Design Rules, viz obr. 7.). Pravidla jsou exportována do textového souboru s koncovkou RUL.

Obvykle si návrhář vytváří základní technologické sady pravidel, které v počátečním stavu hned po otevření nového prázdného PcbDoc souboru do něj nahrává. Tyto sady pravidel pak například mohou obsahovat pravidla typu:

  1. 1. varianta  šířka spoje a izolační vzdálenost minimálně 0,2mm, vrtání minimálně 0,8mm
  2. 2. varianta – spoj/mezera 3mil, vrtání 0,3mm

070 RulesExportDetail

Obr. 7. Export nebo import návrhových pravidel

Efektivnější je však mít připravené celé šablony prázdných PcbDoc souborů, kde jsou již nastavena jak všechna návrhová pravidla, tak složení plošného spoje, barvy vrstev, názvy mechanických vrstev, nastavení DRC systému atd. PcbDoc soubor tak může být nastaven v analogii s předchozím příkladem na:

  1. 1. varianta  2 vrstvý plošný spoj s parametry spoj a mezera min. 0,2mm, vrtání min. 0,8mm, 4 dokumentační mechanické vrstvy a základní DRC
  2. 2. varianta – 12 vrstvý (s patřičným složením vrstev) plošný spoj s možností slepých děr, spoj a mezera min. 3mil, vrtání min. 0,3mm, 10 dokumentačních vrstev a DRC s kontrolou impedance spojů a vyrovnávání jejich vzájemné délky

Při zahájení projektu (respektive po dokreslení schématu) si do projektového adresáře návrhář nakopíruje připravený PcbDoc s potřebnou technologií a již pouze definuje velikost plošného spoje a nahrává ze schématu součástky. V případě prostého nahrání samotných návrhových pravidel by bylo potřebné provést daleko více nastavení ručně.

Podobně se řeší i vytváření dokumentačních a výrobních podkladů, kdy se do cílového projektu kopírují OuputJob skripty s potřebným nastavením všech výstupů. Ty jsou pak ve všech projektech generovany jednotně a návrhář šetří i svůj čas. Téměř vždy jsou potřebné nějaké lokální změny a úpravy, ale ty zaberou nepoměrně méně času než kompletní nastavení.

Závěr

DRC systém Altium Designeru je poměrně mocný nástroj, který pomáhá předejít chybám způsobeným převážně lidským faktorem. Hlavní motivací je to, že správně vytvořený systém pravidel umožní automatizovaně zkontrolovat plošný spoj v době jeho prvotního vývoje, ale i při změnách, které nastávají při postupných modifikacích a aktualizacích výrobku podle současných požadavků v průběhu celé jeho existence. Kvalitní nastavení pravidel je tedy i investicí do budoucna, které vám pomůže další úpravy provést jednodušeji bez intenzivního studování několik let starého návrhu a jeho technologie výroby nebo tento krok alespoň výrazně zjednodušit. Obvykle si ani neuvědomujeme, kolik různých kritérií do návrhu zapracujeme, a přitom nejsou nikde explicitně uvedena. Ta se však z naší paměti bohužel obvykle vytrácí jako první.

Ač je DRC systém velmi flexibilní, tak není schopen postihnout všechny případy, které reálně nastávají. DRC pak alespoň pomůže odbourat běžnou rutinu kontrol, kterou má návrhář na svých bedrech, a ten se pak může více soustředit na komplexnější záležitosti. Předvýrobní kontrola v DFM nástrojích je především u složitějších plošných spojů velmi prospěšná i po důkladné DRC kontrole, jelikož tyto nástroje jsou zaměřeny více na výrobní technologii a mohou tak do kontrol zahrnout i jiné parametry.

Od verze Altium Designeru 10 se DRC systém používá i ve chvíli, kdy je generována výstupní dokumentace a výrobní podklady pro serverový archiv Vault, a díky tomu může systém odhalit stav, kdy návrhář omylem vygeneruje tyto podklady bez toho, aby spustil kompletní DRC kontrolu. DRC reporty mohou být navíc i přímou součástí dokumentace.

 

[1] http://www.altium.com/files/Altiumdesigner6/LearningGuides/TR0110%20Query%20Language%20Reference.PDF
[2] http://wiki.altium.com/display/ADOH/Query+Language+Reference
[3] http://wiki.altium.com/display/ADOH/Design+Rules
[4] http://wiki.altium.com/display/ADOH/Enhanced+Display+of+DRC+Violations

Gooter Gap 2

Retry

Retry s.r.o.
Vondrákova 1254/2a
635 00 Brno, ČR

Sídlo
Křivého 7
612 00 Brno, ČR

 

 


tel: +420 549 210 082
fax: +420 549 210 711

e-mail:infoproti_spamuedatools.cz
web: www.edatools.cz